Category Icons patch for WordPress 2.8

Update 2 : the patch is not needed anymore as there is a new version of category icons (2.1) that is compatible with WordPress 2.8+. Download it to resolve the issue.

Update 1 : here is the detailed procedure (thanks to ycs for the tip) :

  1. deactivate the plugin,
  2. log out of the admin control panel,
  3. replace the old category_icons-panel.js in the js folder by this one,
  4. clear your browser cache,
  5. close all open browser windows,
  6. open a browser, log in and reactivate the plugin.

Please leave me a comment if it’s not working.

Latest version installed but WordPress says it can be updated

WordPress says that there is an update for Category Icons Widget, whereas you have the latest version installed :

I don’t know why, but when the WordPress server (api.wordpress.org) is asked to check for updates, it gives this response for the widget :

[category-icons/category_icons-widget.php] => stdClass Object
(
[id] => 1258
[slug] => category-icons
[new_version] => 1.8.6
[url] => http://wordpress.org/extend/plugins/category-icons/
[package] => http://downloads.wordpress.org/plugin/category-icons.zip
)

The version received is 1.8.6 instead of 1.1. So, the solution to get rid of this, is to edit the file category_icons-widget.php and modify the line :

Version: 1.1

to this :

Version: 1.8.6

In the next version of the plugin, it’ll be corrected.