Latest version installed but WordPress says it can be updated

WordPress says that there is an update for Category Icons Widget, whereas you have the latest version installed :

I don’t know why, but when the WordPress server (api.wordpress.org) is asked to check for updates, it gives this response for the widget :

[category-icons/category_icons-widget.php] => stdClass Object
(
[id] => 1258
[slug] => category-icons
[new_version] => 1.8.6
[url] => http://wordpress.org/extend/plugins/category-icons/
[package] => http://downloads.wordpress.org/plugin/category-icons.zip
)

The version received is 1.8.6 instead of 1.1. So, the solution to get rid of this, is to edit the file category_icons-widget.php and modify the line :

Version: 1.1

to this :

Version: 1.8.6

In the next version of the plugin, it’ll be corrected.