What’s new in 1.8 ?

The plugin is now compatible with WordPress Mu.